Tile Studio Ltd - Phone Lines – Incident details

Phone Lines

Resolved
Degraded performance
Started 2 months agoLasted about 2 hours

Affected

Phone Lines

Degraded performance from 11:51 AM to 1:56 PM

Updates
  • Resolved
    Resolved

    This incident has now been resolved.

  • Investigating
    Update

    Phone lines are still functioning but with limited capacity

  • Investigating
    Investigating

    Our Provider is currently investigating an incident.