Tile Studio Ltd - Studio Tiles website is experiencing issues – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
All systems operational
Studio Tiles website is experiencing issues
Resolved
Major outage
Started about 2 months ago
Lasted about 9 hours
Affected
Studio Tiles - E-Commerce Website
Major outage from 9:20 AM to 6:24 PM
Updates
Resolved
07 February, 2025 at 6:24 PM
Resolved
07 February, 2025 at 6:24 PM
This incident has been resolved.
Identified
07 February, 2025 at 9:20 AM
Identified
07 February, 2025 at 9:20 AM
We are continuing to work on a fix for this incident.