Tile Studio Ltd - Intermittent Phone Lines – Incident details
All systems operational
Intermittent Phone Lines
Resolved
Degraded performance
Started about 1 month agoLasted about 3 hours
Affected
Phone Lines
Degraded performance from 10:29 AM to 1:13 PM
Updates
Resolved
Resolved
This incident has been resolved.
Identified
Identified
We are continuing to work on a fix for this incident. Please get in touch via Email or our Whatsapp if you experience trouble getting through on our Phones